stockholm/default.nix

13 lines
384 B
Nix

import <nixpkgs/nixos> {} // rec {
lib = import ./lib;
systems = with lib; let
namespace = getEnv "LOGNAME";
systemsDir = <stockholm> + "/${namespace}/1systems";
in
genAttrs
(attrNames (filterAttrs (_: eq "directory") (readDir systemsDir)))
(name: import <nixpkgs/nixos> {
configuration = import (systemsDir + "/${name}/config.nix");
});
}