stockholm/makefu/5pkgs/devpi/py3-fix-encoding.patch
2016-10-19 21:57:23 +02:00

12 lines
344 B
Diff

+++ a/setup.py
--- b/setup.py
@@ -26,7 +26,7 @@
def get_changelog():
- text = open(os.path.join(here, 'CHANGELOG')).read()
+ text = open(os.path.join(here, 'CHANGELOG'),encoding='utf-8').read()
header_matches = list(re.finditer('^-+$', text, re.MULTILINE))
# until fifth header
text = text[:header_matches[5].start()]